Requirements

In order to use Care Go you will need either an iPhone running iOS 10 or later or an Android smartphone running Android 9 or later.

Care Go will be able to send alerts to your friends and family no matter if they own an iPhone or Android smartphone, however, only iPhones will be able to receive critical alerts even if they are in silent mode. Android phones will receive standard push notifications, which will be affected by the users volume settings.

x